Monday, August 6, 2012

kdesu won't start apps in superuser mode

For a long time i had a really annoying bug in kde. This weekend i updated to kde-4.9 and found out that it's still present. The problem was when you press ALT+F2 and type "kdesu systemsettings" (or another program) the password prompt showed up but than nothing happen. I found a few topics about this, most notably here and here.

I had some time and since i could reproduce this problem in my virtual machines too i've started to track down the problem.
After a few hours of searching i finally found it. The reason was because dbus wasn't build with the useflag X enabled.
Adding the X useflag to dbus solved the problem.
 echo "sys-apps/dbus X" >> /etc/portage/package.use  

After creating a bug report on bugs.gentoo.org devs also mentioned that if you're using a desktop/kde profile you shouldn't hit the problem because there dbus would be build with X enabled anyway.
I never though about that but it's true, i'm using a default amd64 profile. The desktop/kde profile do enable to much for me.
Anyway, i also found another issue. ligthdm-kde also need dbus with X enabled otherwise it wont start.

No comments:

Post a Comment